Android Telephony API Issues

Last update: April 2017

 

Phones with Android 5+ that still do not implement fully API 17 telephony functions

There are phones with Android 5 or Android 6, i.e. API 21+, that still do not fully implement API 17 telephony functions (they implement API 1 telephony functions!), which limits drastically our app's features for those phones. This has as consequence, for example, not showing any LTE neighbors, and not showing PCI (since no such info is provided). These are manufacturers' issues and not ours.

Continue Reading

Android Dual-SIM issues

Last update: May 2016

 

Not all devices implement fully and correctly the Android telephony interface. If the device does not provide dual sim signal strengths to the API17+ Android telephony interface, then the dual sim functionality of our app can not work. This is not our limitation, but it is a device/firmware issue.

Non-MediaTek devices with Android < 5.0 do not support our dual SIM app functionality. It is an Android/device issue.

In Release 3.12.0 we deployed a largely updated dual SIM engine. 

If the dual SIM functionality does not work in your phone, please email us the system info/feedback from the app settings.

 

  • 1
  • 2